Spite 2.2 Beta – New Siri Clone Replaced Spire On iOS 5.1

SpireWe all know, Spire tweak allows us to use Siri voice services on non-iPhone 4S devices, unfortunately however Spire is not yet compatible with Apple’s newest version of iOS 5.1. Its developers stopped updating Spire to support 5.1. What approach will allow us to use Siri on non-iPhone 4S devices?

Fortunately, the developers just changed the name from Spire to Spite, Spite is still a Siri clone, it exists in the Cydia tweak form and currently in the beta phase. Allegedly, Spite is a much faster than spire, that depending on your device and how many gigabytes of flash storage it has, Spite may or may not work. Thus, it is important to keep in mind that on some devices Spite will not work and you will have to restore for you device to work again.

To use Spite on your device, you just need to install it via Cydia

How To Install Spite Tweak on non-iPhone 4S devices

Note: If you are using an iPod Touch 4G or 8GB, you will have to restore. So do not proceed. If you are using an iPhone 4 8GB or 16GB the Camera.app will not work. So proceed at your own risk.

Step 1: Launch Cydia and add the following repository:

repo.technetec.com/beta

Step 2: Find Spite 2.2 (5.1) or Spite 5.0.1 and install it (this depends on your system is iOS 5.0 or5.0.1)

Step 3: Reboot your device, the tethered jailbreak users can boot tethered with RedSn0w.

Note: The i4Siri proxy will not work, since when you try to install it, it says you need Spire. It should be updated when Spite is out of beta though.

Lei Cao
Love to see you here, I'm a geek, love tech and life. Thank you for reading my article, hope we can be friend, find me on Google+